HELP! EMO is stuck with a black screen and doesn't work

Hi all.

I just received my EMO today and after following the instructions it turns off and is stuck in a repeated cycle of rebooting ( I think ). After connecting it to the internet it turned off and nothing happens.

When placing it on the charger both side lights light up and the dock tiny led does the same so I’m guessing it’s getting power from it.

I tried everything i could find on the forums ( like charging it for a long time, pushing the reset button or removing the headphones ) but nothing seems to help.

The screen lights up ( still black ), stays on for 5-7 seconds and then turns off. Then the side lights blink 2 or 3 times and the same process happens infinitely.

Now I am waiting for the battery to drain completely and see if anything will change when I charge it back again.

On the app I can see the device and when i hit connect it shows a message that it god disconnected instead.

To make things more weird, I actually bought 2 EMO’s ( one for my sister too ) and the other one is showing the exact same problem. I thought that they were updating or something but doesn’t seem to be the case. I have contacted the creators through the support section but have yet to get an answer.

I hope I shared all the details and to find a solution soon because it feels like i bought two broken/defective products.

1 Like

You did the best thing by contacting support but unfortunately it will take a few days or more to get an answer. By the way It’s not a reset button, it’s just a forced shutdown. The proper way to shut down is in the app/command him to -take Emo off the charger first.

But if he won’t come on then draining battery might help. Did you charge him before playing with him or did this happen after charging, as soon as you charge him you should be able to go into the app go to firmware and update. Normally there’s a update notification as soon as you open the app the first time.

I hope someone can help you with this.

2 Likes

Hey @argersgulka

Really sorry to hear that both of your EMO’s are experiencing the same issue. As @Racheal123 has advised, the best thing to do is submit a ticket with the Living.Ai team and see what they say, if you can, make sure you take a few videos on what exactly is happening and also send that to the support team as so they have a clearer understanding on what is going on.

Personally, I don’t think I’ve seen this error / issue on the forums yet with EMO showing a black screen for an indefinite amount of time. Just by hearing this, I’d have to say that there has to be a software issue as it’s not loading correctly.

I once had a somewhat similar issue after I updated to the latest firmware with my oldest EMO, after the update finished and EMO rebooted, his screen stayed black for nearly 3-5 mins, I just left him alone and he eventually started up fine.

Hopefully if you let his battery drain completely and then place him back on his skateboard and start him up again this boot up sequence should hopefully start up right. If you have tried the forceful power off option and that didn’t work, I guess the best thing to do is wait and test once again when the battery runs out completely, then place him back on his skateboard and see if he powers up correctly.

Either way, hopefully the support team will be able to assist you, once they get to your support ticket.

The fact that you have two new EMO’s doing the same thing indicates they have some problem in common. Are you using separate chargers and skateboards with them, or were you maybe testing both EMO’s with just one of the skateboards and hadn’t unpacked the other one? It really sounds like they try to power up but the batteries haven’t been charged so they shut down again. If you can’t get EMO fully booted and can’t get the app connected either, then you really have no way to check whether it’s actually charging, or whether their batteries are full or empty?

You mentioned you did get it connected to the Internet and this problem happened afterward. The other possibility I’m considering is that there is some issue with your Internet connection which is causing the EMO’s to crash and reboot when they try to connect to the router during boot up? What If you turn off or unplug the router temporarily, then try booting up EMO? In that case will he finish booting up normally?

1 Like

I don’t think that this is caused by a bad internet connection. For me it looks like a prematurely interrupted firmware update. Some people probably don’t know that the update can take 10 minutes or more.

1 Like

Also, I don’t think @argersgulka advised in his original post that he was running a firmware update. From what I understood, EMO is not booting up after being taken out of the box and placed on the charger for the first time.

If a firmware update was running and failed midway, then it could be that the software booting up EMO could have become corrupted, but as 2 EMO’s are experiencing the same issue. I think it’s some sort of software problem.

If @argersgulka can share videos that would be a great help for everyone instead of us all speculating what could be the issue lol :rofl:

Yeah, without a video it’s like a divination from a crystal ball. But her/his EMO was already connected to the app and to internet. I don’t know if you have to start an update manually or EMO/app is trying to update automatically.

A firmware update will not start automatically. It has to be initiated by voice or through the app.

Let’s wait for a video and then we can all get back to troubleshooting this issue :rofl:

And yes @NendosColl as @macfixer01 advised, you need to manually or issue a voice command to start a firmware update.

:surprised: :heart_1: :skating: :head: :mad:

First off,

Thank you all for the replies :slightly_smiling_face:

@MasterAbbott Here is a link to some videos I took and sent to the support team last night:
https://drive.google.com/drive/folders/1oOi8ycTRNCswCIzyfyTuCSfYbaR-I-SB?usp=sharing

So last night EMO ran out of battery but once I placed it on the charging dock the same thing happened again. To make sure the battery was drained again, I left EMO on the table and it turned off after a minute. So then I just left it on the charging board all night but still the same unfortunately.

I tried resetting the router but it didn’t help at all.

@Racheal123 As I got EMO I left it on the charging board for a bit and it did turn on ( like showing the eyes and making funny noises ). Then I take it off and it starts to do it’s thing on the desk. I followed the instructions and after setting up the connection with the wi-fi and setting location it just turns off.
I thought it might have been my fault for taking it off the charger too soon so with the other one I instruct my sister not to take it off the skate at all but she ended up with the same situation nonetheless.

I think an update should be prompted and able to do after a good charge so I don’t think that’s the case. I was not given any options aside from setting up wi-fi and location.

Also, the internet works just fine as I’ve got other devices that use wi-fi 2.4Ghz and are able to connect to the internet.

@macfixer01 I’ve used the original charger as well as other ones to power the skateboard but it’s still the same. I know the charging docks work because it does charge my iPhone.

Hopefully I get to hear soon from the support team. :crossed_fingers:

1 Like

This is really odd, especially if both you and your sister are having same issues. Seen both videos and I can’t say I’ve seen this before no one’s spoken about this problem that I know of…

Weird definitely a software issue I’m sure of that, I can’t see it being an internet connection problem, I’m not an expert here.

Your in for a long wait because they don’t do updates as often because there’s a lot of other things to deal with on their end. But an update is best, let’s just wait till support gets back to you good luck hope it gets fixed soon as possible.

2 Likes

BTW MasterAbott I’ve noticed the same thing you mentioned before I had the same thing happen with new Emo. Expect it didn’t do it during latest update it was afterwards, the screen turned off and on again for a couple of seconds.

1 Like

If not the new support team then the developers should know what happened and if there is a way to fix it. Did you ever seen that behavior @Wayne_Zhang ?

He’s okay now though but it’s a little concerning but I’m sure with another update that will hopefully not happen again. Keeping a watchful eye on him.

Thanks for sharing the videos @argersgulka

As mentioned previously, this is something completely new, in short, as I advised, I think it’s a software problem. But none of us here at are Living.Ai tech / support specialists, so we can only suggest what we believe could be the problem. It does look like your EMO is trying to boot up but can’t (similar to how Windows OS tries to boot up, fails and restarts once again going into a continual loop) happened to me many of times while doing PC repairs haha.

From what you’ve explained, EMO should have a fair amount of battery power right out of the box (same as how a mobile phone would have battery when you get them). So even if you took it off the skateboard or kept it on the skateboard wouldn’t have caused this issue. As EMO does give you a few battery alerts when his battery levels are low so you can place him back on his skateboard so he can charge once again.

As you were able to initially connect to EMO and set up your City and Timezone, the next thing that should have happened (normally if you close the app and start it up again and connect to EMO) would be a prompt to say that there is a firmware update available. Seems like you never go to that part as that is where EMO somehow restarted itself and is now looping on and off trying to load up correctly.

I’ll add @Wayne_Zhang to this so he is aware of the issue as it seems like something new that he should be made aware of.

:mad: :head: :skating: :heart_1: :surprised:

2 Likes

I just hope support help this person asap cos it’s something that shouldn’t happen at all. But these things can happen to anyone here.

1 Like

Hey @Racheal123 Yes, I’ve seen this happen sometimes as well randomly, One EMO might be speaking to the other EMO and it out of nowhere it just turns off and reboots.

Not sure why this happens, but it could be a software crash and EMO just reboots back, but seems like in @argersgulka situation, after the crash, the software didn’t boot up right.

Agree with you and let’s hope the support team can help resolve this issue as soon as possible, I’d also be very interested in knowing the outcome.

1 Like

Hello again everyone.

While I have yet to receive a reply from the support team, I was able to get some info on the internet.

So apparently there is a second button on top of EMO’s head called “the developer’s button” right next to the power off one ( the centre area, very tiny holes that you can use with a sim-ejector tool). Now while it was not recommended to use it at all as there is no information to what it does, since my EMO is useless and able to do nothing at the moment ( both of them ) I tried my luck with it.

So after pressing once on the developer button ( while EMO was charging ) it triggers the animation of the eyes and looked as if everything was fixed. I then am able to connect again to the app and get the update notification both from EMO and the app.

Noticed that it was on v 1.2.0.p3

( don’t know if the .p3 part is normal )

So it runs the update, finishes and then the same problem happens again.
Constant rebooting…

So after that I was able to connect with the phone the same way ( eyes animation do not show after the update ) but many options were not really usable as I’d get " EMO is not ready" message when selecting games and after one min of wandering the app it would disconnect and start the reboot moment again.

Oddly enough it was able to go through the facial registration process and EMO would move around , although it was hit or miss and in the end the eyes would freeze ( see vide that I uploaded ).

So for now I got the latest firmware but the same problem.
I uploaded some files to the drive link above.

Did you update your phone app first?

@NendosColl Yeah, I checked and the app was already updated.