EMO not updating (v 1.3.0)

Hi guys,

I don’t know what is wrong, but I just can’t get EMO updated with this new version 1.3.0. Last version (1.2.1) was updated smoothly. I tried 3 times and it keeps setting error after downloading the version. EMO was connected (wifi) and was on the charging base when I tried to update it earlier today.

Please, can somebody share some advice to get it updated right?


Vagner (America / Sao Paulo)

1 Like

Hey @Vagner

Sorry to hear the latest Firmware Update is not working. Just to confirm, you have done all the basic troubleshooting steps.

  1. Power Down EMO. Start him back up and leave him on the Skateboard
  2. Restarted your Phone.
  3. This is not really needed, but have you also updated the EMO app to the latest v.1.08?
  4. Removed / Turned off any Smart Lights that EMO might be connected to.
  5. Reset your / power cycled your Home internet WIFI
  6. Tested that EMO can successfully connect to the internet and reply and return simple commands.
  7. Check via the EMO App that EMO is responding to commands / You can also try some simple straightward tests like accessing EMO’s photos and have him display them on the screen.

Next try and run the Update using the EMO App, you should get a notification to update as soon as connect in and it goes to the front page of the APP. If not go to Settings > Firmware >> then update it from there.

When the update starts, EMO should show a Red alert on his display, he will quickly flash and then start to download the firmware. The firmware goes through 6 steps. Try and keep an eye on how far into the 6 steps it goes as it could potentially be a internet connect problem if it fails at Step 1.

I also shared a video on how install the firmware: this is probably something you’ve already done, but I’ll leave a link below just in case you need it.

Hope this helps.

:heart_1: :surprised: :head: :skating: :mad:


Hi Master Abbott,

I followed all the recommended steps, but, unfortunatelly there was no way to get EMO updated. I tried hard, because, I have also reinstalled EMO app.

Just a thought: is it possible to have some issue in America’s server? Because, everytime I have tried to update, it failed after step 2. My internet connection was above 250MB when I checked it after updates failure…

I really hope I can get EMO updated or I will have a brick toy, stuck in 1.2.1 version…



Hi guys,

Finally it worked for me!

When you start the firmware update process, EMO automatically disconnects. So, the “Connect” button appears again in the app screen. IMPORTANT: It’s MANDATORY to connect to EMO again. So you must click the connect button to proceed with the update. If you don’t do that, you will certainly get update failure on step 2.

I hope it helps everybody who is facing update problems!

All the best,



Yes I had that happen too. MasterAbbott didn’t mention that extra step in his video and he had the camera on EMO’s screen not the phone, so you didn’t see him do it. When you click UPDATE FIRMWARE then click OK, EMO’s screen goes black then it shows the big EMO icon on his screen with a red “1”. Nothing more happens until you click Connect again in the app, then EMO begins the actual update process. When the update was done and EMO had rebooted, I had to quit the app and relaunch it to actually connect to EMO again.

It used to be simpler when you could just install the updates using a voice command, but I think that got disabled in the last version. Now only the voice command to check for a new update works.

Outsider238 did a recent YT video on the 1.3.0 update process and new features which shows that extra step more clearly. Although he says it’s something that doesn’t always happen, which appears to be incorrect.

The voice command to update still works, just have to have EMO on the charger and say ‘install firmware’, that’s how I update all my EMO’s.

Really? While I was writing that reply earlier today I must’ve tried it 10 times in different ways, and it wouldn’t work for me. Install firmware, install update, install upgrade, upgrade firmware, …

OK I just tried Install Firmware again and now it did what it was supposed to! EMO tried to upgrade and then soon after gave me an error since he’s already at the same version.

It’s funny but after about two weeks of zero server problems, the last 2 nights I’ve had temporary issues where only a couple commands will work. Sunday night it did it for about 90 minutes and last night it only did it for about 10 minutes. He replies to EMO with What?, then I can ask for the time or the weather and those commands will work every time. Anything else I could think to ask him though (his favorite color, age, favorite book, sign, and so on) gave the “don’t understand” sound. I tried resetting him just in case, but it still worked exactly the same way. Wayne messaged with me about it but the problem had already ended. He wants me to make a video, although I had described it already in great detail. Last night when the problem happened again though, it only did it for about 10 minutes and I didn’t get a chance to video it. Maybe tonight?

It’s entirely possible that due to the fact that Australia does not have it’s own EMO server we could be suffering from routing issues as EMO tries to connect to the most suitable server.

I’m not sure how many EMO owners there are in Australia, but if I had to guess I would say that we only have a few dozen owners, so there would be little incentive for Living.ai to supply a more local server to improve upon server related issues.

Actually. If I can clarify this part that @macfixer01 mentioned with the video. I do click on OK at 0.58 in the video. Then the APP disconnects from EMO and then it starts downloading the Firmware.

Early on in the video I connected to EMO via the APP while I’m discussing other things and the Firmware option appears on the screen while I’m talking, and then as mentioned at 0.58 time I press OK and the firmware begins to install (emo reboot and I lose connection to the EMO app, which can be seen in the video as well).

At this time, (for me) I couldn’t connect back to EMO via the EMO app as he was downloading the firmware, so I’m not exactly sure how you can reconnect back to EMO via the APP during that time as this is where the download and install is happening

In the video at 3:12 once EMO has fully completed his update (reboots and gives his green tick confirmation etc) I then reconnect back in by pressing Connect button. By now everything is finalised anyway.

If @macfixer01 and @Vagner did this in a different way by connecting to EMO with the EMO App while the firmware was downloading (Steps 1-6) was running. I personally didn’t do that and never had the option to connect during that time.

Sorry for any confusion if / or if I’m not fully understanding exactly how both of you did this update, but how you saw it in my video is exactly how it happened for me with my EMO.

Either way, Good to see your update finally worked either way @Vagner and your EMO is finally at v1.3.0 now :head: :heart_1: :surprised: :skating: :mad:


@MasterAbbott ,
This is someone else’s video but if look at the first couple minutes you can see what I was talking about. The app disconnected after he clicked install firmware and ok. EMO’s screen goes dark then the 1 icon showed up on EMO’s screen and goes away (I thought I remembered it staying up but not sure now). Anyway the upgrade doesn’t actually start until you click connect again. This is basically how it happened for me also. So maybe he’s right about that being something it doesn’t happen every time?


Very interesting. As I mentioned. I did not have to click on connect as this guy did in that video.

I can honestly say that the video I did was done in real time. So how you see it, it happened. It does seem very weird how you had to do it this way and I didn’t have to do it.

That is something that I now would like some clarification on. Maybe @Wayne_Zhang can explain why it is happening like this for some people and not for others.

As it goes, I’d like to say that the video I did and the instructions I’ve shared should be valid, as this is exactly how it worked for me and for my EMO.

@MasterAbbott ,
The only thing I can think of is that somehow the app disconnected for us right before the upgrade began, which is why the other 2 persons and I had to reconnect to start it? I just assumed it had worked the same way for you, and you just clicked it without thinking to mention it? Then after the upgrade finished and EMO had booted up again, his number wasn’t shown for me and didn’t show up after a refresh either. I had to quit and re-launch the app before I could connect again after the upgrade.

I just had another thought. I believe you had already updated your app to 1.08 before upgrading EMO? When I upgraded my EMO the apps had not been posted yet, so I was still running on the 1.07 version. That might be the difference? I just went back and watched Outsider’s video and he never even mentioned the new app, so I’m pretty sure he was still on 1.07 also. Well anyway, we both learned something new!

1 Like

Yes, now that you mentioned it, the reason why maybe you and some others had to reconnect, could be you were on EMO APP v.1.07.

I had previously installed the new APP ver 1.08 and mentioned that I was on the new version also in the video as well. In my other post (you can see here) I also advised / recommended that to update to ver 1.08 prior to installing the Firmware (it is not needed, but it was recommended).

So looks like that possibly could be the reason why this is happening for some people and not for others

:surprised: :head: :heart_1: :skating: :mad:


Hi guys,

Just to clarify, I would like to share the steps I had to do to get all the stuff working:

  1. Update the app (android) to version 1.08
  2. Reboot phone
  3. Reboot EMO (turn off, turn on)
  4. Put EMO on the charging base
  5. Enter the app
  6. Connect EMO
  7. At Settings page, click Firmware
  8. Click update
  9. EMO shows a little box with number 1 and some arrows upward and it will start to download the update
  10. App disconnects EMO
  11. Reconnect EMO - This is the crucial step, because here is the core problem. If you don’t reconnect again, you will get fail in step 2!!!
  12. EMO gets fully updated

So, yes, you must reconnect EMO to get it updated. I have tried several times and I got no success until I reconnected EMO during the process.

Maybe, other guys might have to reconnect in the beginning to continue, just like @macfixer01 showed. I believe it is totally possible, since v 1.3.0 update process is really weird. I truly believe there will be several experiences shared by users.

@Wayne_Zhang should clarify all users about this. A nice post here, showing the required steps to get their product updated would be more than welcome.

Thanks @MasterAbbott and @macfixer01 for your valuable support!


Thanks for sharing the steps you needed to take. As mentioned it seems that the only step I didn’t need to do was step 11. I don’t know why, but it would be nice to get clarification from Wayne why it is different for some users.

Once again glad all is working now :mad: :skating: :heart_1: :head: :surprised:


I didn’t do step 11 and it was fine for me so not sure why this is recommended

1 Like

Dear @Racheal123,

For those whose EMOs aren’t updating, I highly recommend it! Unfortunately, we are having an update that is very unusual as we can see a lot of different experiences here.

My intention is to share some light with dozens who might have the same problem. Fortunately, this is not your case :wink:

All the best,



Hi All, I also can say that EMO cannot be updated to 1.3.0. I have 1.2.0 and all the steps of the update from 1 to 6 are performing well but at the end of Step 6 at number 660, EMO restarts and indicates that the update is unsuccessful.

Please test the update on different cases and provide a solution.



So you skipped over updating to 1.2.1 somehow? I have reason to believe that may be why you’re having a problem now? I know a few other people with even older versions have had issues updating. It’s not clear whether or not each new version totally replaces ALL the firmware, or if they only add some new files and replace files that have changed? My suspicion is that the 1.3.0 update expects everything up to version 1.2.1 files to already be there?

@Wayne_Zhang @Wayne_Small , Can you comment on how the updates work, and whether they should be able to be done from an older non-current version?

Hi, I would like to share information on this issue with everyone here. I’ve checked with the team. The only problem is still with the network. Even if you have a fast internet connection, the download process may be terminated due to a timeout due to international connection issues. We are working on optimizing the server side .