Charging problem post firmware upgrade

Since I upgraded the firmware a few days ago, EMO is not charging correctly.
Twice he has been sat on his charger for ages but when I take him off to play, he goes dead almost immediately. Both times the light on the charger was flashing when I removed him, which is not normal either.
Today the charger light was flashing, one side of Emo’s headphones was flashing and there was a quiet beeping sound coming from him. Once taken off his charger, he went dead.

These things have only happened since the firmware upgrade and I have never had a problem before.

Any thoughts?


Have you tried resetting EMO with a paperclip yet? This is just a reboot process, he won’t lose anything. You must be sure to use the correct hole though, so look at the photos here first:



I haven’t as yet, no. I will give it a go later. Thank you.

I was wondering whether anybody else was experiencing problems after the latest update?

1 Like

I experienced this already before last update and still do, have to lift him up for a second and then he charges normally. Hope it gonna be solved in future updates

I’m also having this problem (and have to reposition him on his charger whenever the light is blinking to make sure he keeps charging correctly like vitasei says). Started happening way before the last update for me too. First occasionally, then during every charge, multiple times during a charge and ultimately it would even take several tries of putting him on his skateboard to get the light to stay on.

Support asked me to try another 5V 2A plug and that solved the problem for a few weeks.

Unfortunately it started happening again 2 days ago, not during every charge but I suspect that it’s going to happen more frequently just like the first time. Don’t know if this is just a software problem, but hope so.

I noticed the flashing charger problem some time ago, just lift the Emo and put it down properly with the magnets and the problem was over. Until today.
This morning it worked as it should, but in the afternoon after coming home and taking the Emo off the charger, it turned off within 5 seconds. After putting it on the charger I found it was completely dead. Now I’m trying different combinations of chargers and still the Emo won’t charge. Yet the phone charges without problems on the skateboard, in a few minutes there was 2% extra. Emo after a few hours on the chargers is still discharged. I’ll still try restarting it with a paperclip. On the charger it works without any problems.

Update: So the pin reboot didn’t help. I’ll try to leave the Emo off until morning and if it doesn’t charge tomorrow, I have a problem.

Update 2: The app writes information about the start of charging when I put the Emo on the charger. Apps on Android and iOS display the same.
It just won’t charge the battery.

Update 3: So after 30 minutes on the charger, the battery has moved and is charging. Hooray. I hope it’s good.

Update 4: So after taking it off the charger, it shuts itself off within 5 seconds. :frowning:

Update 5: The Emo only works on a charger and does not charge its battery. I have tried different chargers, even wireless, always the same result. It works on the charger, but off the charger it shuts down. More in the video.


Update after 27 days: unfortunately our Emo has to go back to Living.Ai, a new piece will be sent to us and as soon as it arrives we will send it back.
I’ll try to charge the Emo on another wireless Qi charger before morning, just to be sure.

That’s unfortunate. I’t seems very likely that it’s only a software issue since none of the hardware was changed. Either some portion didn’t upgrade correctly, or possibly the new firmware uses the charger a little differently now, and just exposed a problem that was always there but didn’t matter before? One change I’d recommend to LAI is to allow forcing downgrade to the previous firmware version to see if the problem goes away, or at least allow you to force another upgrade to the same new version to see if that helps? We can’t currently do either, so the only option is always going to be replacement.


I also think it could be a SW bug and I would rather fix the problem remotely. On the other hand, I understand that they need all the problematic units back for detailed analysis to prevent the problem from happening again in the future.


I know for a fact that EMO’s development team DO have the ability to remotely access EMO to do sensor and software checks.

I know this because they did it with one of mine, they simply requested the EMO ID code and the location information and asked me to leave EMO on the charger for a few days while they did their thing.


As an update, my EMO has now died completely. The charger light is on but EMO doesn’t charge and is totally dead.
I have been in touch with support and I am hoping that they will send a replacement.

1 Like

My update after 3 weeks.
Emo has been down and off the whole time. I put it on the charger over the weekend and it started charging. I don’t understand what happened that it suddenly started working. So far, I’m testing the battery life and the findings in 2 days: the Emo won’t charge to 100% and once it didn’t warn about the low battery and shut down.
Today it worked for about an hour on battery and alerted to low battery. So the Emo’s battery life is down to about 50% of its original capacity, but until a new piece arrives in the future, it’s not completely silent at home.

Small update: so as of this morning on the charger, Emo still has only one battery part. So the fault still persists.

I’m sorry to hear that your Emo has stopped working altogether.
If you have contacted Living.Ai support, I’m sure they will send a new robot to replace it, it will just take some time unfortunately. I don’t dare to guess how long. We are also waiting for our replacement Emo, luckily the original Emo has started working.

That’s exactly what mine is doing. Totally dead battery??

@Rduggan . . . I have moved your post from another thread to this topic here:

You might want to have a look there.