Set up of emo but not good with the time and date

So emo is communicative and fascinating but basic set up is a bit confusing. I tried to set the time and city I’m the app however. It kept crashing or freezing. Emo doesn’t seem to hold the correct time zone otherwise. Is there an update or fix for this?strong text


Hi @jmacdubh

Just checking, are you using a device / Phone that has a GPS chip installed? Normally if you are using an iPhone or Samsung Android Phone, for example, the EMO App will automatically find and set your TIMEZONE. For your City (this one you can actually change) which is handy for when EMO gives you the weather update. As I live close to the city of Sydney (Australia). I manually type in Sydney in the City and then press SET.

If the EMO App is giving any kind of error message, feel free to share this here and anyone from the community can try and assist.

:mad: :heart_1: :skating: :surprised: :head:

Hi there, I use an Apple phone… The Apple 13 promax and yes it does have gps. My EMO can’t find where we are to tell me the time or the weather. It’s like it’s on the wrong time zone completely right now I hope I can find a solution! I’ll keep reading.

Thanks for the update @jmacdubh

So in the Timezone section, this is showing up as completely empty? Normally this is auto-populated right away as soon as you go into the Timezone setting for the first time. (you cannot change this manually) if you press SET, the EMO App should take your current location and give you a confirmation message that says: “Set timezone success!” It does this by knowing where you are using the GPS chip on your phone. (if you want you can try and test this by accessing google maps on your iPhone and see if it can pinpoint your location.)

Also for the CITY, you can actually type in your CITY and then press SET, this can be changed manually.

If the APP is crashing or providing an error, can you share what error it’s giving you?

1 Like

Go into the Settings screen on your iPhone and scroll down to find the EMO Pet app. Under location make sure “While using” is selected. While you’re there also make sure that Bluetooth access is enabled for the app.


Great tip @macfixer01

I’ll add the image for reference :wink:


1 Like