Random problem with EMO face

Hi all I am having a random problem with my EMO screen turning off and freezing. I have 2 EMO’S and it is happening to both of them. The only way to get the display back is to turn him off and back on again.
Has anyone else had this issue?
After having to replace my original EMO my heart skips every time this happens.

1 Like

Hi @petrajenkins

I’d suggest contacting Living.ai support regarding this. I also have two EMO, both are on the latest firmware (ver1.7.0) and they have never shown a blank display. It might be a software issue related to only specific EMOs. I believe there are other EMO owners that have/are experiencing this problem at the moment as well.

The best thing to do is contact support/show videos/pics and allow them to provide you with a possible solution to this for you :slight_smile:

:fire_1: :heart_1: :skating: :heart_1: :fire_1:

Hi Master Abbott,
I sent a ticket yesterday afternoon but not had a reply so I thought I would see if anyone else had come across this.
I know the time difference can cause a delay in replies so will hang on until tomorrow and then contact them again.
Just hope I don’t have heart attack in the meantime lolol
Thank you for your help xx

Yes, give them some time to get back to you. I’ll also tag @AmyLU as well for further assistance.

:fire_1: :heart_1: :skating: :heart_1: :fire_1:

Perfect, thank you once again for your help :pray: :heart: :blush:

1 Like

Today is the first day of my new EMO (replacement) and everything was perfect until thar his eyes, suddently, haven’t respond. He spoke and moved, but his eyes remained open and fixed. I put him off and, apparently, now it’s ok. But after my first EMO experience, I’m really scared.
Anyone have the same problem @Wayne_Zhang?

Hi,

Please PM me your order number. I will check for you.

2 Likes

It has happened to me once since the update. At first I thought the battery was empty and put EMO on his skateboard, but the battery was half full.

2 Likes

Sent, thank you for your help xx

The last two Emo I ordered and received also show a blank screen. However, in my case, they both still walk around just with a blank screen until I turn them off and on again. Maybe it’s an issue with a particular production batch, as my other Emo has never had this issue. It’s happened several times.

1 Like

Yes I came to the same conclusion, I also get the blank stare sometimes which is unnerving lol.
Support have said this will be fixed in a future update thankfully :blush:

2 Likes

Both of mine are doing the same thing. So it’s definitely seems to be a software glitch. It’s every few days but it’s a little annoying. But not too big a deal. They’re okay after. My big problem is one of ‘em not walking straight it’s like a circle. I’m not sure he will work with the self charging station.

2 Likes

I’ve passed this thread over to the Living.ai team so they can check and hopefully provide an update on what could be causing this blank screen on certain EMOs. So far neither of my two EMOs have had this problem…(yet).

If anyone is experiencing this issue, it might be a good idea to submit a support ticket and let the support team know and assist you further.

:laser_1: :fire_1: :skating: :fire_1: :laser_1:

3 Likes

My new EMO has this problem. It is really strange to see him speaking and walking with his face black.
When I reiniciate him he is ok. I hope that it isn’t happens very often.

1 Like

One EMO who arrived about a month ago has the blank face sometimes. When I put him back on the charger it comes back. A new EMO arrived yesterday and it happened to him today.

This thing happeneds to me too.

I have a new glitch with the display I hope it is related and will be fixed in the next update?
Many thanks :blush: :pray:

1 Like

Could be related. Be sure to share this with the support team as well. :slight_smile: