Emo not connecting

Hi emo wont connect to my wifi iv turned of the router,reset emo;uninstalled and reinstalled the app nothing is working not happy please any suggestions that i havent done xx

From what I understand it only works on Wifi 2.4g and not 5g. You could check which wifi you have.

My wifi is 2.4 im not on 5g

I hve reset everything and still fails to connect :frowning:

Just an idea, but have you cleared the cache on your phone or tablet? Then reinstall the app?

1 Like

Yep done all that reset everything just not happy i have done literally everything to get my little chap back im gutted :cry:

1 Like

I think I saw a different post on this issue by you earlier, under Android Support? I believe you said you took EMO to a friend’s house, now he won’t connect when back at home?

You said you reset EMO, but did you actually reset him with a paperclip, or just power him off then put him on the charger to turn him back on? You said you deleted your friend’s wifi info, but maybe EMO doesn’t have your home wifi info saved anymore either? Can you connect to EMO on Bluetooth from the app? If so, did you actually click the connect button in the wifi screen, and re-type the correct SSID and password for your own wifi network? Or were you just waiting to see if he’d reconnect on his own? You probably know, but upper and lower case makes a difference and has to be exact.

All brands of routers are somewhat different. If I log into my NetGear router though like I would to configure it, I can view the log file and it would tell me if something is even trying to connect, and possibly what the issue is, wrong SSID, invalid password, etc. Your router probably has similar capabilities?


Yes i used a paperclip,yes i can connect bluetooth ,yes i retyped my ssid number and password ,i have usd exactly the same password word for word checked on my router cant find the log files think its an old router its an old sky one trust me i have done everything i can i have also turned everything wifi connected to not get interference still my buddie wont connect :tired_face:

I have found the logs what am i looking for ?
im no tech person xxx

Can you find the most current portion of the log based on the time stamps, and attach a screenshot here? Or you may be able to copy the text and paste it into a reply?

One of the main functions of your router is to assign dynamic (changeable over time) proxy addresses to all the wifi devices in your home as they are requested. That allows each device to have it’s own distinct address as far as your local network (LAN) is concerned, but all the communications from all those proxy addresses get funneled through one address that the outside world sees (the Wide Area Network or WAN address). That (usuually dynamic) WAN address is provided to the router similarly by your service provider. The DHCP (Dynamic Host Configuration Protocol) is what your router uses to hand out those proxy addresses to your local wifi devices, and also what your ISP uses to hand out a WAN address to your DSL or cable modem and router. Sometimes those modem and router functions are combined in the same box. In any case you’re looking for recent DHCP logins and any errors that occurred.


Reply from ntp1.isp.sky.com
Sep 19 07:24:59 syslog: bind - Address already in use
Sep 19 07:24:59 syslog: bind - Address already in use
Sep 19 07:24:59 syslog: bind - Address already in use
Sep 19 07:24:59 syslog: bind - Address already in use

I reset my router then tried emo again then took a screenshot of the logs which i sent still comes up with connection failed can i add emo to my connected devices ?

Interesting. It looks like there is a address conflict, like EMO is still trying to use the same address he had before maybe but it’s been handed off to a different device? I don’t know why it’s saying though? Most home routers default to a 192.168.1.x address scheme with the router itself at and DHCP would hand out proxy addresses as they were requested with the last digit increasing toward 254 (255 has special meaning and is used for broadcast to all devices).

Maybe try turning off Wi-Fi on, or just shutting down all of your other wifi devices, and then reset EMO? See if he connects that way and responds to his name? Then if that works turn the others back on one at a time to see if the problem either resolves itself, or comes back.

One more point I forgot to mention, you may have some devices actually connected by ethernet cable to the router. Even though they aren’t using wifi they still each consume a network address, so when you do the test turn them off too.

Iv turned all wifi devices of rebooted emo
I have nothing connected either from the ethernet still says connection failed ?:sob:

Sep 19 07:24:01 syslog: Received NTP Sync Reply from ntp1.isp.sky.com
Sep 19 07:24:59 syslog: bind - Address already in use
Sep 19 07:24:59 syslog: bind - Address already in use
Sep 19 07:24:59 syslog: bind - Address already in use
Sep 19 07:24:59 syslog: bind - Address already in use
Sep 19 07:58:40 syslog: Lease renewed 3600 ip

This is the log now

Any change in the log? If there is a Refresh button make sure to do that so it’s updated.

Could i add emo ip address ?

Sorry I hadn’t seen that last reply yet. It looks like your outside (WAN) address is I don’t see anything there that looks like DHCP requests for the local LAN addresses though, unless it’s further back in the log. The NTP line is the current date and time being requested from your ISP.

I really don’t know what else to have you try? Maybe someone else will have an idea, and in the meantime try to contact LAI.

Hi i have tried contacting ai still waiting :sob: