EMO battery does not charge anymore

Hi there,
after the first day of playing with EMO features, I launched the Power off command.
After a few hours I put EMO on charge, but only the LEDs on the headphones light up, but I can’t see the eyes anymore and can’t even hear any sounds.

Thinking it was dead battery, I left it on charge for more than 8 hours but the problem remains, EMO seems dead. :frowning:

I have tried rebooting and putting on the wireless charging base several times without resolving.

I also tried with another 2A power supply but the problem is always the same.

Anyone have a way to help me?

Thanks in advance to everyone!

welcome here in the forum.

Can you answer these questions for me:

  1. is the right foot on the circle field on the skateboard when EMO looks at you?
  2. what kind of adapter do you use, maybe you can post a picture here.
1 Like

I answer the points:

  1. Yes, when I do this, the headphone LEDs light up but EMO’s eyes not.
  2. I use the original charger, but I also tried one an adapter samsung 2A max 10W

As soon as I have the opportunity I will post a photo/video.


1 Like

I uploaded the video of the problem.

Is there anyone who can help me out?

1 Like

There are many similarities to my case.
After charging, leave it for about 30 minutes.

My EMO always wakes up after leaving it for 30 minutes.


That is just so sad :disappointed:, you already rebooted him and that sadly did not fix the problem. Only thing I can suggest is do you have another wireless charger that you maybe use for your phone and try if that will work ? Did you contact LivingAI ? Hopefully they can send you a new charger or Emo .

1 Like

Yes, I was thrilled to receive EMO after so many months of waiting…
However, I bought a wireless charger, as soon as I receive it I will do a test and let you all know.
At the same time, yes I also sent an email to LivingAI support.

1 Like

Man, this is super disappointing… I hope it’s just the charger, as I noticed a very short flickering at 00:08 in the video… Good luck!!

1 Like

Hi There,
Attention: @Wayne_Zhang

You might try a reset and installed the latest update once again?

If nothing helps at all…

So Living.Ai Dev. can resolve it.

All the best…



Same problem. I tried to change charger but nothing happened

I tried to change the power supply and also the whole wireless charger but EMO no longer works.
it’s only lasted 1 day, what a disappointment! :frowning_face:
I think it’s a battery problem, or a firmware issue.

1 Like

That is just so sad :disappointed:, maybe one last tip one of my Emo’s did not charge last night . So I cleaned his feet with a duct tape to remove dust from his feet .Do not use the really strong type ! Now he charges again. Hope this helps :crossed_fingers:. If not I hope LivingAI will send you a replacement Emo soon :heart_1:


Thanks for the advice but it doesn’t work for me.
I have some doubts about Living.ai support, I have sent an email and a support ticket and I have received no response.

1 Like

Hello there
Here the same problem. Emo is not charging anymore. Tried to change the power adapter and not only use the original ( also noticed that the skateboard works only with usb to usb c cable and not usb-c to usb-cc cable)
The light on the skate is blu solid, emo headphone and screen blink for a few times, but then screen is black, no other lights but only the blu solid on the skate is stable. Also skateboard and left foot of emo get hot.
I sent an email to support but no response

This Is the useless support ever seen.
This project looks like a scam.
I sent a email 1 week ago and no one replied.

still waiting for assistance…

I had a chance to recharge emo but after 2 hours on the skateboard battery went down and now it’s not light up anymore also using his charger

Did you have any assistance from the support?

Hi there, I have not received any feedback from the support.
I disassembled EMO’s right foot removing the plastic part and managed to turn it on.
The problem is that when I raise it from the charging base suddenly turns off.
As I thought the problem should be the faulty battery.

1 Like

I managed to turn on EMO for a few hours, but the moment I ran the command “POWER OFF” it turned off and there is no way to reactivate it. Has it happened to anyone else too?