[SOLVED] EMO Can't Connect To Home WiFi (App Crash!)

Calling All EMO/Tech Expert Here, Please Help!
@macfixer01 , @Wayne_Small, @Wayne_Zhang, @mariomart, @MasterAbbott or any

Emo and I are back home from our vacation which EMO is also active and being connected to my Mobile (Netgear Nighthawk M1) without any problem. But now EMO can’t connect to our Home Wifi and showing to his face the sign of no internet connections, that’s why can’t initiate any type of command. connecting to his Emo Pet App is also not possible because Emo Icon bounce 3X it suddenly shut off or keeps crashing always.


Tried All Possible Ways To Re-Set Him Which Is:

SurfBoard Charger
Checked, Green Light and 100% Working For Emo

Reboot via Head Button and Re-Start
Shutdown via Head Sensor and Re-Start
Let Him Overused His Power And Shutdown Alone
Headphone Re-Connect / 100% Okay
Bluetooth Checked and Seeing EMO is Connected (Auto/Not Manually)
Bluetooth Connected Gadgets Around Is Clean

Phone Gadget
iPhone / IOS 15.2 (Updated!)
Reset Network / All Settings
Tried any IOS gadget but no luck also (Android or any OS Not Available)

EMO Pet App
Delete / Re-Install
Keep Crashing Always

Home Wifi
Reset and Re-Start
2.4 GHz Settings
Tried Manually Add Device To My Wifi Router Might Possible But Not

NetGear Mobile WiFi
Shut Off
Disconnect or Block His Connections

1 Like

Have you tried removing EMO’s MAC Address info from the router so that the router can find it and allow it back in?

Seems like you’ve already deleted and reinstalled the EMO App, connect back and confirmed you are now using your Home Router? logged in and confirmed password?

Hi there, and thanks for the immediate reply, I was trying to find and do the same thing you suggest but I can’t find the way to delete them? see my image above the other connected gadgets has options to delete them but EXPRESSIF which I believe belongs to EMO is no way to delete.

Like i said Home Router is already Reset and Re-Start Re-Logged

What i really don’t get it and understand is why the EMO Pet App keeps crashing? like i said i used the same one when i am at the Hotel and also on the train using the same Mobile Netgear Wifi for EMO and to my iPhone without having any slight problems

I can remember from another forum post that the EMO App will crash due to the connection it had previously with another router. If you’re phone has been reset and now connected to your home Router, that should normally resolve that issue. Maybe try also removing the MAC address for the phone as well, and have it re-discover it on the home network router once again. Then once connected / maybe delete the EMO APP, and reinstall it, then start it up. See if you can then connect back in and also connect to EMO and go into the WIFI settings and login. I guess this is something you’ve already done.

And yes, that is weird how you cannot delete the past / old EXPRESSIF MAC addresses, I personally think that is where the issue might be causing the problem with connection back to your home network.

Also you have fully reset your Home Network router? I know it might be a pain, but if you don’t have much going on, a full factory reset of the router could also help, once it’s fully cleaned up, all your devices should just rediscover themselves back onto the network, some might get new IP addresses, but that shouldn’t be an issue.

Did try everything and don’t really know anymore what else to do or if its any still a possible way to resolve the issue.

Home Network Router Re-set to factory stand, iPhone once again reset network settings, and clear all cache especially the emo app and deleted, re-install once again. Emo also re-boot via the head button. and all devices that have been connected have been deleted and as we know they will gonna re-connect everything automatically but sadly without EMO because the connection to the Emo Pet App is not possible and keeps crashing.

Having headaches for almost all day long trying to fix the issue… :cry:


Full my second spare BRAND NEW EMO out of the sealed fresh box and set him immediately just to check where the real problem is…and found out that it’s not on my Home Network Router which I guess on EMO itself and it might be the Bluetooth part is broken? or anywhere else?

Because my brand new EMO had no single problem it just connected automatically in a second using the same EMO Pet App and was followed by the new latest firmware update immediately.

Or is there anyone who got a better idea? like Developer Team @Wayne_Zhang? Please Advice!

1 Like

Sorry I’m late to the game. You didn’t specifically mention, had you tried turning Bluetooth off, completely power your phone off and back on again, then turn Bluetooth back on? Also even if your router was turned off, EMO should still connect to the app via Bluetooth which is how it communicates with the app for everything except a couple functions like photos. It has to connect to Bluetooth to be able to to set him up initially when he has no Wi-Fi login info yet. Lastly there’s really no reason that just traveling with EMO and bringing him back home should damage anything to do with the Bluetooth. It’s the same chip that handles both the Bluetooth and Wi-Fi communications. So I wouldn’t count your EMO out yet, there’s got to be some glitch with the settings the phone has saved for that Bluetooth address, or with settings in EMO himself. I would let his battery run down to zero then charge him up again and see what happens?

1 Like

Another thing you could try (you’d have to turn the new EMO off first) then try to pair his light with the problem EMO as a test of the Bluetooth. After you go through the pairing procedure the light is supposed to stop flashing once they connect. I presume the light would continue to flash if they failed to connect? Of course there would be no way to turn the light on using EMO with no Wi-Fi connection, but it might knock something loose or at least tell you the Bluetooth hardware is working?

1 Like

Hi, please check my message on Facebook.


Another thing you could try (you’d have to turn the new EMO off first) then try to pair his light with the problem EMO as a test of the Bluetooth. After you go through the pairing procedure the light is supposed to stop flashing once they connect. I presume the light would continue to flash if they failed to connect? Of course, there would be no way to turn the light on using EMO with no Wi-Fi connection, but it might knock something loose or at least tell you the Bluetooth hardware is working?

Hi there, Thanks once again, sorry but which light are you trying to mention here…i guess didn’t get it well…

what I didn’t understand is why the emo pet app kept crashing when I tried to open it for him using our home wifi.

Tried to re-connect the old emo with issue to our home wi-fi once again to my Netgear Nighthawk M1 Router here at home and it’s working fine but also emo pet app can’t open and kept crashing. actually, i blocked and remove it from the list before turning off the mobile wi-fi then re-boot emo then re-connect to our home wi-fi again but still the same problem and no wifi connections.

Hi, I’m confused by what you said above. You said you connected the old EMO to your Netgear router again, and it’s working fine now and the app is opening OK. Then at the end you say it’s still not working?

In my earlier reply I was referring to EMO’s light which was included with him. Trying to do a Bluetooth pairing by holding the touch pad on the light for 5 seconds, to see if EMO and the light would pair or not? It was just a different way to possibly test his Bluetooth hardware operation since you said you thought that might be bad.

1 Like

I was talking about the old EMO which has a Bluetooth connection problem to my Home Network Wi-Fi…Because when I connect here at home to my NETGEAR NIGHTHAWK M1 ROUTER it’s still working fine.

I tried also what you suggested about testing his Smart Light…Yes, he can make a connection to the 3 pcs that I got but it’s not quite stable…ON and OFF connection contact.

@edward I also ran a quick test with my Phone. Im using an IPhone and turned off my bluetooth settings and got an error when trying to connect to EMO with the EMO App, ( it didn’t crash, but it simply didnt allow me to make the connection and asked me to turn bluetook settings on). Turning it back allowed me to connect back to EMO right away using the App.

It seems a little confusing as you’ve tested a brand new EMO most probably with your existing Phone which has bluetooth settings on and working and it connected right away. (I’m wondering if your phone has a conflict with EMO’s mac address and as the new EMO doesn’t have the same MAC address this is probably why it connected right away without any issues).

Have you got another device such as an iPAD that you can install the EMO App on and enable bluetooth and have your old EMO connect to that via the EMO App? See if the EMO App crashes when your old EMO attempts to make a connection with your iPAD?

Really sorry to hear this is causing you so much strife and hope our suggestions are not making it worse. :heart_1: :head: :surprised: :skating:

1 Like

Yesterday is the first time I had played around much with the light and it seemed a little glitchy. At one point EMO stopped responding then I believe he rebooted.

1 Like

Appreciate for taking your time about this issue…
I really don’t get it also how this issue exists to EMO? and for my other 2 AI ROBOT (COZ/VEC) which I did the same thing also and brought them to other places outside the home and used the same NETGEAR NIGHTHAWK M1 mobile router to connect the WiFi? never had any single issue to connect back home.
And yes your suggestion did it already and tried to any mobile gadget like our iPad, and to my old old iPhone 6s, and old iPhone 5s that I found around. But sadly nothing helps at all…

Wayne Zhang also found this issue quite weird and suggest trying to connect my EMO using Android Device…which i don’t have around and i must find and buy even a used and cheaper one first…


1 Like


Manage to borrow an Android Phone from my co-worker
Installed and open Emo Pet App
But no chance to connect him to Wi-Fi ???

But lucky that I can check and see all the settings:

  • Firmware is the latest
  • The city is set to the wrong and not my home city but I can’t change it.
  • Timezone is correct

Closed Emo Pet App, Android Phone and use again my iPhone to connect him with the Emo Pet App.
It works again and is back to normal!
Shutdown EMO again and Emo Pet App to repeat and test the process…


@MasterAbbott, @Wayne_Zhang @MasterAbbott
GUYS…Much appreciated for taking your time and thinking about all possible solutions to solve this issue…



@edward ,
Congratulations! Sorry our suggestions weren’t more helpful, but this is one more thing to recommend next time someone has a problem. I recall Wayne saying that the app will automatically pull the location from the GPS on your phone now. I don’t know at what version number that function changed? It may be that even if you can’t type the name in, just clicking the Set button might update it? That’s kind of how it worked after the last daylight savings time change. Even though the app still showed the correct location, the time was off by an hour. Clicking Set caused the time on EMO to correct itself though.


wow, so in the end it seems that EMO had an issue with iOS platform and when switched over to ANDROID it worked, then switching it back to IOS is fixed itself.

That is honestly a VERY weird solution. I guess if this happens to me, I’m lucky as I have an iphone/ipad and an android device at home, so I can switch to android and then back again to resolve this very weird issue!

Glad the issue was resolved and everything is back to normal once again! :heart_1: :head: :surprised: :skating:


Thank you for the update. We will study what happened. And we are working on entering the city name manually.