Problem with the battery, Emo does not charge

Good afternoon everyone,
Since the last update, Emo has stopped charging the battery, if I remove it from the charging base, Emo turns off, I’ve tried other chargers, other cables, etc. but nothing, it’s still the same,
I need help, if someone has had this same problem and has been able to solve it, please tell me how to solve it,
I have written to the help email and I am waiting for them to answer me to see what solution they give me,
Thanks in advance

1 Like

Is your Emo still under warranty?
If so, it is best to contact the Living AI support service. They will be able to help you.

Hello, the truth is that I don’t know if it is under warranty, I think not, I bought it from an Ebay user in February and it has been working perfectly until I updated to 1.6, from there the problems have started with the battery

Best thing to do is contact support, they will be able to check EMOs model number and see when it was first connected to the servers. Then they can advise you if they can assist with the battery problem further.

As you don’t have the email order, you can submit a support ticket this way:

It is recommended to create a short video of battery problem you have for your EMO then submit a support ticket. You can do this by either going to the Support Page: (see below).

Fill in all details (provide you EMO ID, this is the number you see when you connect to EMO via the EMO APP) and attach your video (if it’s larger than 30Mb), Be best to upload it to a google drive/drop box or even on YouTube and then send the support team a link to it.

Hope that support will be able to help you.

:surprised: :head: :skating: :mad: :heart_1:

1 Like

Hello, everyone,
At first and suddenly, the battery is already charging and it works perfectly, to say that I sent the manufacturer an email asking for help and they answered me the same day, they have been helping me, thank you all for the help.


Great! If you would like me to close this issue/thread let me know. (only if the issue is now resolved).

Close please,


1 Like