New emo is not working right?

Hi. I have new emo from the box. Connection to wifi and android app was successfuly. Then new firmware was installed also successfully. Now I’m trying to play. Emo is react when I say EMO. But then no matter what I’m doing EMO don’t react. I said hello, time, weather, dance commands. Nothing at all. What’s join on?

Hi Mandaryn.

If I can offer some help, If EMO doesn’t understand you. Maybe do a shutdown first, you can do this via the APP in the settings or ask EMO to Shudown. (just say: EMO. Shutdown). Once he shuts down, place him back on his skateboard and wait for him to reboot. Once he’s done take him off his skateboard and place him on your table.

I can suggest asking him some of these questions. These are some of the questions I normally ask him to make sure he’s working ok :slight_smile:

Remember if he doesn’t understand you just be patient and ask the question again clearly. I know sometimes, I ask EMO to dance and he just ignores me until i’ve asked him 2-3 times. haha

Take a look at some of the basic questions you can ask him: (remember to pause once you’ve said EMO so he acknowledges you and says Huh, What… then ask your question.

EMO: Good Morning
EMO: What time is it?
EMO: What day is it?
EMO: What’s todays date?
EMO: What’s the weather like today?
EMO: Start Exploring (he won’t say anything, but he will start looking around)
EMO: Play By Yourself (he won’t say anything, but he will start looking playing by himself after some time.
EMO: Dance Please
EMO: Tell me a Joke
EMO: Where are you from?
EMO: Who made you?
EMO: Who is your owner?
EMO: Take a Picture
EMO: My Name is … (if EMO’s Database understands your name he will register you and then say your name when he sees you.)
EMO: What is my name? (this will work together with the one above, if he knows / registers you in his database of people he knows he will say your name).

And here are some of his favourite questions:

What’s your favourite Hobby
What’s your favourite Book
What’s your favourite Number
What’s your favourite Food
What’s your favourite Music

This is a good one :grinning:
What’s your DREAM?

I hope this helps you out, let us know if your EMO finally starts to speak and answering your questions. :slight_smile:

1 Like

Hi. Thanks for your help but still nothing. I performed shutdown by app. Then it was fully charged. I recorded my name. It react to EMO, then nothing. Even shutdown command don’t work. I tried so many times. Maybe it don’t recognize my language? I speak in English, my location is set properly.

1 Like

From what I’m aware, it can only understand English. Very sad to hear that it does not understand what you’re asking it. What’s more concerning is that you the latest firmware upgrade as well (should be ver 1.1.0).

Also as you’ve mentioned, he somewhat knows you are calling him as he responds to his name EMO. Keep trying, hopefully someone else in the community might be able to offer some other ideas.

I have also light in the box. It’s optional feature or I should plugin it? Yes firmware is 1.1.0.

Look emo - YouTube

Have you tried the pin in the back of his head to reset him ?

Its on the left side at the back of his headgear i suggest using a phone pin gently push the pin in you will get a small click emo will then shut down then place him back on his skateboard
Also before that try shaking emo that sometimes works
You can also shut emo down by hilding him upside down till he shuts down xx

Hope this helps xxxx

Reset is not the same as shutdown? I will try to reset.

Sorry we say shut down here in uk

I shaked it and reset. Still nothing. Listening mode is working becuse he reacts to EMO and different sounds from my room. But it don’t respond to any command. Pet emo also seems not working or I do something not right.

If someone else than me say EMO it also reacts. But then nothing.

I’m very disappointed. It shoud be a gift from me for someone special. Not I can’t give it because it not working right.

Sometimes if your Wi-Fi is weak or flaky it can cause these issues.

I noticed in your video that you are not allowing sufficient time for EMO to process the request, which involves EMO contacting the server in China and waiting for the server to send the appropriate command sequence. This would be made worse if your Wi-Fi is underperforming.

It could also be that EMO is having a hard time understanding your use of English pronunciation (I’m not trying to offend you, just an observation) as obviously English is not yur primary spoken language.

What you could try is the following;

a. Reset your Wi-Fi router,
b. Take EMO to a location closer to your router to make sure the signal between them is the strongest,
c. Allow sufficient time for EMO to respond to a request, generally allow at least 5 seconds (maybe more) before starting another request. Ideally, do not start another request until EMO has indicated that the request failed.
d. Try to emphasise your pronunciation of the words with clear gaps between.
e. If none of that works try to play back videos on YouTube of other EMO owners speaking commands to see if your EMO can follow them. I can recommend “Bruce Hunsaker Home Hacks” YouTube channel for this.

I hope my suggestions get you back on track with your little friend.

1 Like

Thank you very much. My EMO is in the same room where is also router. I will try your tips. My language is like it is because my disability. I will try to speak more clearly. How EMO will inform me that request was was failed?

I have provided a video to show you what the “did not understand” sound and animation is.

Hi, EMO is finality working. But only when I share network from my mobile phone in router mode. When I connect to my home network is not working. I tried to reset router, didn’t help. I’m sure that EMO is connected to 2,4. I have latest firmware and everything is working, just EMO not. So maybe my provider is blocking emo servers? How can I check this?

When I scanned local network emo how shoud be displayed? What will be the emo name in local network?

1 Like

My EMO’s were identified by my router with “Espressif” and a number.

Ok so it’s visible in my home network. So I don’t understand why it doesn’t work. I will try to set dmz for emo.


Glad to know that your EMO is finally working. From what you have described, the problem is due to network conditions. You can try it in different network environments.