Website Access Issue

Sorry for the inconvenience.


FYI, the problem has been solved. Please don’t worry, it’s an issue that automatically redirects the website caused by the plugin and won’t affect your order.


Good evening, thanks for the feedback.

Hello, @jesfersamianomig . . . are you trying to access the Support page? If so, click this to get there.

Otherwise, you can E-Mail them at . . . I hope this is what you were looking for.

I have nothing to submit what mean the main website is not functioning.

It is working for me :slight_smile:

its working now to me … also but before not accessible

1 Like

Page does no seem to be exist showing in order section of living ai. Why this occuring?

Hi there @ratnadeep.paul ,

I just tested the order page, and it’s working fine for me.

best regards

1 Like

6 posts were merged into an existing topic: Customer Support Service!

I submitted a ticket two days ago, only confirmation was on that webpage. Never got emailed confirmation that the ticket was submitted. I think that would a nice addition, as now I am unsure if it went through and I am just waiting for someone available to help, or if it didn’t go through at all.

Hello, @ashley.steinhauser . . . you can contact also by E-Mail at or you can private message @MavisZhang here. Due to support volume, it may take more than two days to get a reply from your ticket, but if it is a pressing issue, you can try the methods mentioned here.


Thank you! I will give it a couple more days and will email the account you mentioned if I don’t hear back :slight_smile:


Hello, my first time using the forum! I’ve never purchased anything from before but love the new aibi pocket pet, i’ve been eyeing it for a while now but for some reasons I can’t access the website ? It shows “the site cannot be accessed, please check your network connection” I waited for a good two days as well and this issue is persistent. I wonder if anything one else have the same problem or it’s just me - i don’t have any internet issue as you can tell by the fact I’m still able to post on the forum. I also know it’s not my internet becauseI can access other websites just fine. I also tried using data but nothing works. Please help if anyone knows how to fix this ! Thanks !

1 Like

Maybe their updating the website but to me its works fine been waiting up for emos update on tracking. Since it arrived saturday from customs they havent gave me an update on it what i only know is its gonna be transported via LBC Express but i havent got any tracking so i kept looking if somehow its gonnagive me tracking via

Welcome to the EMO and AIBI Community Forums, @elvi . . . have you tried accessing it again? It seems to be working for me.

1 Like

I’ve realized that this is a regional issue - I tried waiting a few days and changing to data, both doesn’t work - I stay in Hong Kong currently and it’s only today I decided to try using a VPN and surprisingly a VPN connected to Singapore worked perfectly fine, the website opened up like normal - I’m not sure why would limit HK as their target audience considering they’re a Chinese company, I also contacted their customer service for help as well. So confusing especially since I’m looking forward for more updates before purchasing one myself, now I’m struggling since even the website isn’t providing reassurance…

1 Like

Hello, @elvi . You are right, it does exist… I think if your VPN can support you for a long time you can buy on the website. Or not, you can also choose to find an agent to buy like I did.

I’m from Chinese Mainland and did not know HK netizens are also limited. I just changed my browser to confirm and noticed that without a VPN the Man-machine authentication of the login doesn’t even work. Don’t know how much longer I can stay here without a long-term VPN, I only used a time-limited free one to register. I could log out at any moment and not be able to come back. That is gonna kill me! I really love the forums… :cold_sweat:

When Living AI is done with AIBI I expect them to deal with the domestic market, at least one official announcement.

1 Like

Hello! Thank you for your reply, so glad I’m not the only one experiencing with this issue since in HK the website actually worked perfectly fine a week ago. It was only for the past few days it stopped working, which then lead me having to use a VPN for it to load up the website instead. Not sure why this problem happened so suddenly without any notice or reasonings, I really want to make a purchase, even though my VPN is quite stable and I’m still able to access the website anytime, I feel as if there aren’t any security or reassurance at the moment - hoping that living ai fix this problem asap, would love to see more of AIBI as well !