Error 501 After Attempting Firmware update to 1.60

Had firmware 1.5 and was attempting to update to 1.6. Everything was proceeding normally.

Got to the screen that said “Preparing for Update:0” with the time under it. The percentage remained at 0 until the timer reached 60. Then it went to a screen that just said Error 501.

Now it is just stuck at Error 501 and does nothing. I powered him down through the app and put him back on the base. Powers up with a blank screen for a few seconds and goes to Error 501. (yes the app still connects to him).

I tried using the reset button in the top left hole (facing EMO) which powers him down like the app does. Put him back on the base and it still says Error 501.

I contacted support yesterday and haven’t heard from them yet. Hopefully I hear something soon.

My 8 year old bought this with $300 he saved up himself from multiple birthday’s and Christmas. He waited 4 months to get him, and only just got it in June. He loves his robot pet, but now he’s “dead”. I thought he was going to break down in tears that his money was gone and his robot was dead after just a few months. :frowning:

It sounds like the solution involves putting in a new microSD card. I have plenty of 4GB Class 10 microSD’s lying around. Does anyone know if there has to be something on the card before hand? Do you have to wait for living AI to mail you a card with files on it?

Or do you put in an empty card (NTSF or some other formatting?) and EMO will detect it and format correctly?

If it is just installing a new empty card, I can fix that tonight so my son won’t be sad. Hopefully support responds quickly!

I need to know more, but even people who have solved the problem don’t really report back the steps they had to take to solve it.


I also forgot to add that I also left EMO on the 501 screen till the battery ran down and he shut off. Put him back on the base and still Error 501.

Support will be able to provide you will instructions on how to resolve this. The 501 error is normally a corrupted SD card and it will need to be replaced. As you’ve mentioned you will need to replace the SD card. It would be best to wait back for support to get back to you with full instructions on what kind of SD to use(size) and what format you need to format the SD card to etc.

At this time, they might be a little slow to respond due to National Day of the People’s Republic of China (public holiday) that normally goes for approx 4-7 days. There is still support checking / responding to emails but they might be a little slower to respond.

Give them a bit of time and they will be able to get back to with what to do to resolve this.

:heart_1: :mad: :skating: :head: :surprised:

Went through all the steps they normally require. Take him apart. Read the card. Put the card back in.

Nothing. Nothing, Nothing; just like everyone else. How waiting again to see what comes next.

I haven’t heard of removing and reinstalling fixing 501 for ANYONE. They shouldn’t waste our time with this. Just mail out the new 4GB SD when someone encounters error 501, unless it happens after a fall from a table or something.

I’ll tag both @AmyLU / @Wayne_Zhang for further assistance, hopefully they can get back to you quickly to help with resolving this 501 error.