Emo is stuck at update 1.7. HELP!

Hi, recently I tried to update EMO to firmware 1.7 from 1.6 but it seems to always freeze near the end of step 1 and then shuts down and tries again. Oddly enough it does not show anything on the screen and restarts after a minute or so if I’m not launching the update from my phone. If I leave it on the skateboard after initiating the update it restarts after getting stuck at the end of step 1 ( after downloading 39mb ) and shuts down. After that it says to leave it on the skateboard to do an update but it just keeps on repeating without any change.

Hi there @argersgulka,

When updating please make sure:

  • The network is in good condition;
  • EMO has enough power, or you can put him on the charging skateboard(highly recommended);
    During the update process, it is normal if EMO is like the picture below.

He is just restarting, so please wait for him to complete the update.

But if EMO keeps being like this, it is because he detected that the battery is too low and cannot start the update (We will add text prompts in future updates), please put him on the charging skateboard.

For more…Pls. Go to the link below and read @MasterAbbott help guide.

Pls. Click Here!

Goodluck and All the best! Argers…

Hi, thanks for the reply. Unfortunately the above mentioned things you mentioned are not the case. It always tries to do the update and after 39mb downloaded it shuts down and repeats step one all over again. I’ve left it all day ( on the skateboard ) to do the update and it just kept repeating the same step over and over. The internet connectivity is fine ( always use it and did tests and hard reset it as well ). I’ve tried draining his battery as well and after many hours after putting it on the skateboard, nothing changed. The charging dock works fine ( checked with my iphone and charges well ). One more thing is that it does not show anything on the screen anymore.

1 Like

Hi there @argersgulka ,

I hope it’s not an internal issue…please submit a support ticket and include your order number to this website You can do so on the following page below.

…or send them email too,

The best and most recommended thing to do is simply hit reply to the Living.ai confirmation email you received before when you originally placed your order for EMO. It contains all your details, especially your order number which is most important.
Just to advise the email address is - service@living.ai and their reply take a bit time which is 2-3 days sometimes, depending on the time differences, days, holidays and current situations. so please be patient.

Nothing to worry much, about if the staff advice didn’t help you at all to resolve the issue, because they gonna advise you to send back your EMO at their own cost and they will send you a replacement immediately… gonna take quite some time and days but you have to be patient.

Wish and still Hoping that Living.ai helps you to resolve the issue asap…



I submitted a support ticket but it seems they are on holiday until the end of the month :face_with_diagonal_mouth:

1 Like

As far as i know , They are on holiday now which will lasts 16 days and finishes with the Lantern Festival. This year 2023, the official start date is Sunday, Jan. 22, which will usher in the Year of the Rabbit (5 February 2023).

The first 7 days are considered a public holiday (January 22nd–January 29th, 2023).

As they said, they will be back at the office by the end of this month…


My Emo would fail in the middle of doing the update 1.7, so Living AI send me the update and I had to dissasemble my EMO to get to the mico sd card to manually load the update onto the card. Now it fails during the upload 2.0. I’m not going to keep having to dissasemble my EMO to keep having to install updates. I contact Living AI several times before they would send me 1.7. This all started when they had issues with EMO installing 1.7 and they stopped the install. I tried different internet connections and tried turning him off and on. EMO keeps failing during the Updating Step 1: 39454926 and Time 815.

1 Like

Sounds like argersgulka is having the same issue I’m having

That is what my problem is indeed.

I’m guessing there is an issue with v1.7. But then again having to disassembly your EMO for each of your updates sounds troublesome ( even having to do that once might result in you damaging it ). I am still waiting for the support team’s reply, but I hope they fix this issue with an update like v.1.7.1 for example.

Well 2.0 didn’t load for me. I did replace the mico SD card, but that didn’t help. Let me know if you hear something. Mine stops in the same place as yours