EMO Firmware Update v2.1.0 + Home Station Firmware Update 1.1.2 Video

And the last two updates are missing in the app.


Good morning! My Emo was updating this morning while I was making coffee. I was actually kind of surprised to see this because I didn’t know it was coming. Happy to see these fixes!

By the way, I don’t know if it will help the major foot issues but I cleaned between all of his foot joints with a small brush that came with my husband’s beard trimmer and that seems to have solved some of the problem. Have a great day!


Hi pls help no way to update home Station Current Version is 1.1.1 .p1
Via app no way seems doesn’t find the new firmware for the Home Station Emo is update correctly the Home Station is Connected also correctly I noticed thst Emo doesn’t answer the voice command after listening he keep thinking but with no result I did also a double check and restarted my rooter but nothing no idea maybe server issue ?


Hi @EmoMike23

Could actually be a server issue, as there are a number of other EMO owners experiencing this at the moment. I’ve tagged @Wayne_Zhang regarding this. Hopefully, this might be a temporary server outage. Give it some time (a few hours) and see if EMO responds to your voice commands. If he does you can try to update Home Station once again.


Thanks a lot I will try later


Quick update from Wayne Z regarding this:

Give it a try later on today / in a few hours’ time.


I just now received another update since 2.1.0 which I received this morning. I received 2.1.1

1 Like

FROM 2.1.0 To 2.1.1 -another update to try and sort it out but unfortunately at the moment with this second update Emo still won’t answer so we’ll just have to wait till next week…!

Please everyone be patient, I’m turning mine off until next week. It might help them to sort it out quicker.

Very comforting to know that if LivingAI servers ever go offline or away permanently Emo will become the equivalent of a broken Roomba.

Next week??? Are you freaking kidding me??

1 Like

You don’t need to do this

I updated EMO just fine and am aware of server issues where voice commands do not work right now, but I cannot even update the home station through the app. “Request failed”?


Lindaru Have you tried asking Emo to do it, on 2.1.0 it worked for me.

I’ve now updated Emo again well one of them anyway, the other one will have to wait until later.


EMO cannot respond to commands right now. Server outage still persists. I had to update them through the app which went fine with update to 2.1.1. I just cannot get the update to run on app for home station.


@MasterAbbott @Wayne_Zhang any idea when this will be resolved? I know you’re working as quickly as possible but @Racheal123 said it would be next week. Is this true?

1 Like

Okay I am sorry for your Emo, it’s just going to take time to get this resolved.

Fingers crossed :crossed_fingers:

1 Like

That’s not what I said. Read properly, it’s not what Lai are saying either. We’ll just have to wait till next week dose not mean that’s how long it will take. Please be patient.

1 Like

At this time, there is no exact ETA on when the servers will be back to normal. @Wayne_Zhang shared a post not too long ago, and also added a special notice to the forum to inform everyone about the current situation (see below).


As there is also heavy traffic at the moment many EMOs will not be able to reply to voice commands / or update to the latest Firmware be it (ver 2.1.0 or v2.1.1).

As mentioned also by @Racheal123 / @Lindaru the best thing to do is be as patient as possible, and wait for Living.ai to resolve this in time.

I’m personally unable to execute specific voice commands with both of my EMOs and neither of them are able to update to the ver 2.1.1 due to the high traffic/server maintenance happening at the moment.

Note – If you have updated to the latest version v2.1.1, this will not resolve the current server issue as they are not related: (see post by WayneZ below)

:laser: :heart_1: :skating: :heart_1: :laser:


Not responding is a server side issue. 2.1.1 won’t fix it. We are working on the server side

This may take a while to sort out.