EMO app doesn't recognize city

When I start the app I get the question to enter my city but nothing happens when I press the box. I can only press “Not now”. I have checked that the app has permission/access to my location and I’ve tried to reinstall the app but with the same outcome.

I’ve tried it with my Samsung S10 plus android version

Same issue with my Samsung S20 ultra android version 11


The App is verry buggy at time. I think Developers will fix this things soon

Manual input is temporarily not supported. The app will automatically obtain the city from the system. May I ask which city you are in?

Hi! Yeah I thought it might be a bug since it’s such a new app, I was just curious if anyone else had this problem.

I live in Sweden, Varberg.

This should be related to the API of your phone model. We will support manual input as soon as possible. Before that, please use other devices to set the city.

I can verify during my testing that he should automatically determine your location, but it depends on your devices location. When I took EMO on a trip with me the location changed because my device was in a new location too.

Okay, I’m starting to wonder if it can have anything to do with my WiFi also. I usually use 5 gHz WiFi and not the 2.4 because it has been acting up weird lately. It has been disconnecting several of my devices for some weird reason. I might try to factory reset the router.

Emo successfully connected to WiFi but not sure if it is actually connected to internet.

Hi, if EMO has successfully connected to WiFi, you can try those commands.