Change to 12 hour clock (request times out)

Hi all! I just got my EMO yesterday and am loving him so far :slight_smile:

I wanted to see if anyone here was also experiencing issues switching to the 12-hour clock, or if you have any advice for resolving. When I try to turn off the 24-hour clock in settings, I eventually get an error that says “Time out, please make sure EMO is up to date.”

My firmware version is currently 2.0.0.p1, so my EMO might in fact be out of date. If that is the case, how can I force an update? There’s no option to update on the firmware page, and I have automatic updates enabled.

I really appreciate any advice you have. Thank you!!


3 posts were merged into an existing topic: EMO Doesn’t Say The Time In 12 Hour Time?

Hi @sarahx2012 the currant version 2.1.1 you can update him by making sure he is on his charger then go into the app in the top right corner and go in to firmware then if it sass latest version is 2.1.1 then hit update.