App Crash with iPadOS 14.0

When I clicked Connect button in app in Ipad with IpadOS 14.0, the app are always crashed. I tried to uninstall and install app again, but it is still not working. Please help.
@Wayne_Zhang thank.


The Discussion Link below might help or give you some idea…

EMO Can’t Connect To Home WiFi (App Crash!)



1 Like

Have you given any thoughts of updating to the latest version of iPadOS? iPadOS 14.0 is quite outdated.

1 Like

Yes, agree with @AtSaturday55, try and update your iPAD to the latest version, then try again, see if it continues to crash.

1 Like

Thank for your solutions, I updated to latest iPadOS, 15 but still crash. iPad gen 8th no LTE. please support me. Tap to connect to EMO and app is crash. Btw, the app is not compatible with ipad ? the sceen is scaled and is not full screen. Please support me @macfixer01

I don’t actually like getting involved in something like this. You give us no information, we don’t know if this is brand new and has never worked right, if it worked before then just happened out of the blue, if you made some changes, do you have more than one device you’re using it with?

Did you actually go to the link which Edward posted up above in this same thread? Go there and read through it. He had the same problem you’re having. He said he solved it by connecting to a Android device temporarily he borrowed and then switching back to the iPad, and somehow that fixed it.

I’m using my EMO with one of the original 12.9 inch iPad Pro’s IOS 14.2 and it works fine. It also works fine with my old iphone 6Plus on IOS 12.1.2 If you only have one device then make sure that your iPad is logging into the 2.4 GHz connection on your router and that you have Bluetooth enabled and the EMO Pet app has access to Bluetooth.

I read Edward’s post clearly. He can’t connect to wifi but I can’t connect to the EMO with app. I have 2 devices, the app in Android Phone (Pixel 4 Android 12) is working fine. But connect Emo in ios app, it’s crashed. I switched many times, both are same network, but it is not working.

Sorry for the late reply. We don’t currently have a dedicated ipad version, we’ll be working on it in the future.